AOH :: ISNQ5091.HTM

Linux Advisory Watch - June 12th 2009




Linux Advisory Watch - June 12th 2009
Linux Advisory Watch - June 12th 2009



+----------------------------------------------------------------------+
| LinuxSecurity.com                                  Weekly Newsletter |
| June 12th, 2009                                 Volume 10, Number 24 |
|                                                                      |
| Editorial Team: Dave Wreski  | 
| Benjamin D. Thomas  | 
+----------------------------------------------------------------------+

Thank you for reading the LinuxSecurity.com weekly security newsletter.
The purpose of this document is to provide our readers with a quick
summary of each week's most relevant Linux security headlines.

This week, advisories were released for evolution-data-server,
apr-util, ntp, drakx-net, apache, dansguardian, ipset, libsndfile,
codeina, gstreamer, gedit-plugins, mkinird, file, libmodplug, openssl,
mod_jk, kernel, and ipsec-tools.  The distributors include Debian,
Mandriva, Red Hat, Slackware, SuSE, Ubuntu.

---

>> Linux+DVD Magazine <<

In each issue you can find information concerning the best use of Linux:
safety, databases, multimedia, scientific tools, entertainment,
programming, e-mail, news and desktop environments.

Catch up with what professional network and database administrators,
system programmers, webmasters and all those who believe in the power of
Open Source software are doing!

http://www.linuxsecurity.com/ads/adclick.php?bannerid=26 

---

Review: Googling Security: How Much Does Google Know About You
--------------------------------------------------------------
If I ask "How much do you know about Google?" You may not take even a
second to respond.  But if I may ask "How much does Google know about
you"? You may instantly reply "Wait... what!? Do they!?"  The book
"Googling Security: How Much Does Google Know About You" by Greg Conti
(Computer Science Professor at West Point) is the first book to reveal
how Google's vast information stockpiles could be used against you or
your business and what you can do to protect yourself.

http://www.linuxsecurity.com/content/view/145939 

---

A Secure Nagios Server
----------------------
Nagios is a monitoring software designed to let you know about problems
on your hosts and networks quickly. You can configure it to be used on
any network. Setting up a Nagios server on any Linux distribution is a
very quick process however to make it a secure setup it takes some
work. This article will not show you how to install Nagios since there
are tons of them out there but it will show you in detail ways to
improve your Nagios security.

http://www.linuxsecurity.com/content/view/144088 

-->  Take advantage of the LinuxSecurity.com Quick Reference Card!  <--
--> http://www.linuxsecurity.com/docs/QuickRefCard.pdf <-- 

------------------------------------------------------------------------

* EnGarde Secure Community 3.0.22 Now Available! (Dec 9)
  ------------------------------------------------------
  Guardian Digital is happy to announce the release of EnGarde Secure
  Community 3.0.22 (Version 3.0, Release 22).  This release includes
  many updated packages and bug fixes and some feature enhancements to
  the EnGarde Secure Linux Installer and the SELinux policy.

http://www.linuxsecurity.com/content/view/145668 

------------------------------------------------------------------------

* Debian: New evolution-data-server packages fix several vulnerabilities (Jun 8)
  ------------------------------------------------------------------------------


http://www.linuxsecurity.com/content/view/149046 

* Debian: New apr-util packages fix several vulnerabilities (Jun 4)
  -----------------------------------------------------------------


http://www.linuxsecurity.com/content/view/149033 

------------------------------------------------------------------------

* Mandriva: Subject: [Security Announce] [ MDVA-2009:099 ] ntp (Jun 10)
  ---------------------------------------------------------------------
  This bugfix release makes it possible to pass additional options to
  the ntpdate utility and for the releases lacking it the ntpd server
  by utilizing the /etc/sysconfig/ntpd file while starting the ntp
  service.

http://www.linuxsecurity.com/content/view/149065 

* Mandriva: Subject: [Security Announce] [ MDVA-2009:098 ] drakx-net (Jun 10)
  ---------------------------------------------------------------------------
  This bugfix update to drakx-net fixes a number of issues: - wireless
  passwords with '#' character were not properly handled (bug #50670) -
  wireless connection settings were not preserved for different
  connections (bug #46010)

http://www.linuxsecurity.com/content/view/149064 

* Mandriva: Subject: [Security Announce] [ MDVA-2009:096 ] perl-MDK-Common (Jun 10)
  ---------------------------------------------------------------------------------
  Mandriva system library (perl-MDK-Common) was not handling
  configuration files that had '#' character inside parameters
  correctly. This update fixes the issue.

http://www.linuxsecurity.com/content/view/149062 

* Mandriva: Subject: [Security Announce] [ MDVA-2009:097 ] drakx-net (Jun 10)
  ---------------------------------------------------------------------------
  This bugfix update to drakx-net fixes a number of issues: - wireless
  passwords with '#' character were not properly handled (bug #50670) -
  wireless connection settings were not preserved for different
  connections (bug #46010) - when configuring Advanced Settings in
  draknetcenter, some variables were not written correctly (bug
  #50807). - e1000e card was added to the list of cards requiring
  additional delay for detecting network connectivity (bug #49335). -
  Cingular connection provider was added (bug #48849). - support for
  AVAHI/mDNS ports was added to drakfirewall (bug #50541). -
  translations were updated.

http://www.linuxsecurity.com/content/view/149061 

* Mandriva: Subject: [Security Announce] [ MDVA-2009:095 ] apache (Jun 10)
  ------------------------------------------------------------------------
  The CVE-2009-1195 patch broke the mod_perl build. Patches from
  upstream svn has been applied to this update that fixes the issue.

http://www.linuxsecurity.com/content/view/149060 

* Mandriva: Subject: [Security Announce] [ MDVA-2009:094 ] dansguardian (Jun 9)
  -----------------------------------------------------------------------------
  There was a bug with the dansguardian build where the path to
  /var/lib/dansguardian was wrongly set to /var/dansguardian. The
  libclamav support has been disabled because of too frequent changes
  in the clamav API, the preferred way to use clamav is to use clamd.
  This update fixes these problems.

http://www.linuxsecurity.com/content/view/149052 

* Mandriva: Subject: [Security Announce] [ MDVA-2009:093 ] ipset (Jun 9)
  ----------------------------------------------------------------------
  ipset released in Mandriva 2009 has a bug leading to a non working
  status, instead starting it gives the following error message as
  output: undefined symbol: __stack_chk_fail_local.  This update fixes
  the problem making ipset work fine.

http://www.linuxsecurity.com/content/view/149051 

* Mandriva: Subject: [Security Announce] [ MDVSA-2009:132 ] libsndfile (Jun 7)
  ----------------------------------------------------------------------------
  Multiple vulnerabilities has been found and corrected in libsndfile:
  Heap-based buffer overflow in voc_read_header in libsndfile 1.0.15
  through 1.0.19, as used in Winamp 5.552 and possibly other media
  programs, allows remote attackers to cause a denial of service
  (application crash) and possibly execute arbitrary code via a VOC
  file with an invalid header value (CVE-2009-1788). Heap-based buffer
  overflow in aiff_read_header in libsndfile 1.0.15 through 1.0.19, as
  used in Winamp 5.552 and possibly other media programs, allows remote
  attackers to cause a denial of service (application crash) and
  possibly execute arbitrary code via an AIFF file with an invalid
  header value (CVE-2009-1791). This update provides fixes for these
  vulnerabilities.

http://www.linuxsecurity.com/content/view/149045 

* Mandriva: Subject: [Security Announce] [ MDVA-2009:092 ] codeina (Jun 7)
  ------------------------------------------------------------------------
  A bug in codeina could prevent its cache to not be flushed properly
  on errors, preventing it to work properly if a erronous file was
  downloaded previously. This package update fixes this issue and
  increase startup delay to 30s to improve login time.

http://www.linuxsecurity.com/content/view/149044 

* Mandriva: Subject: [Security Announce] [ MDVSA-2009:131-1 ] apr-util (Jun 6)
  ----------------------------------------------------------------------------
  Multiple security vulnerabilities has been identified and fixed in
  apr-util: The apr_strmatch_precompile function in
  strmatch/apr_strmatch.c in Apache APR-util before 1.3.5 allows remote
  attackers to cause a denial of service (daemon crash) via crafted
  input involving (1) a .htaccess file used with the Apache HTTP
  Server, (2) the SVNMasterURI directive in the mod_dav_svn module in
  the Apache HTTP Server, (3) the mod_apreq2 module for the Apache HTTP
  Server, or (4) an application that uses the libapreq2 library,
  related to an underflow flaw. (CVE-2009-0023). The expat XML parser
  in the apr_xml_* interface in xml/apr_xml.c in Apache APR-util before
  1.3.7, as used in the mod_dav and mod_dav_svn modules in the Apache
  HTTP Server, allows remote attackers to cause a denial of service
  (memory consumption) via a crafted XML document containing a large
  number of nested entity references, as demonstrated by a PROPFIND
  request, a similar issue to CVE-2003-1564 (CVE-2009-1955). Off-by-one
  error in the apr_brigade_vprintf function in Apache APR-util before
  1.3.5 on big-endian platforms allows remote attackers to obtain
  sensitive information or cause a denial of service (application
  crash) via crafted input (CVE-2009-1956). The updated packages have
  been patched to prevent this.

  Update:

  Fixed packages for CS3 and MNF2 was missing with the last update.

http://www.linuxsecurity.com/content/view/149043 

* Mandriva: Subject: [Security Announce] [ MDVSA-2009:131 ] apr-util (Jun 6)
  --------------------------------------------------------------------------
  Multiple security vulnerabilities has been identified and fixed in
  apr-util: The apr_strmatch_precompile function in
  strmatch/apr_strmatch.c in Apache APR-util before 1.3.5 allows remote
  attackers to cause a denial of service (daemon crash) via crafted
  input involving (1) a .htaccess file used with the Apache HTTP
  Server, (2) the SVNMasterURI directive in the mod_dav_svn module in
  the Apache HTTP Server, (3) the mod_apreq2 module for the Apache HTTP
  Server, or (4) an application that uses the libapreq2 library,
  related to an underflow flaw. (CVE-2009-0023). The expat XML parser
  in the apr_xml_* interface in xml/apr_xml.c in Apache APR-util before
  1.3.7, as used in the mod_dav and mod_dav_svn modules in the Apache
  HTTP Server, allows remote attackers to cause a denial of service
  (memory consumption) via a crafted XML document containing a large
  number of nested entity references, as demonstrated by a PROPFIND
  request, a similar issue to CVE-2003-1564 (CVE-2009-1955). Off-by-one
  error in the apr_brigade_vprintf function in Apache APR-util before
  1.3.5 on big-endian platforms allows remote attackers to obtain
  sensitive information or cause a denial of service (application
  crash) via crafted input (CVE-2009-1956). The updated packages have
  been patched to prevent this.

http://www.linuxsecurity.com/content/view/149042 

* Mandriva: Subject: [Security Announce] [ MDVSA-2009:130 ] gstreamer0.10-plugins-good (Jun 5)
  --------------------------------------------------------------------------------------------
  Multiple integer overflows in the (1) user_info_callback, (2)
  user_endrow_callback, and (3) gst_pngdec_task functions
  (ext/libpng/gstpngdec.c) in GStreamer Good Plug-ins (aka
  gst-plugins-good or gstreamer-plugins-good) 0.10.15 allow remote
  attackers to cause a denial of service and possibly execute arbitrary
  code via a crafted PNG file, which triggers a buffer overflow
  (CVE-2009-1932).

http://www.linuxsecurity.com/content/view/149041 

* Mandriva: Subject: [Security Announce] [ MDVA-2009:091 ] gedit-plugins (Jun 5)
  ------------------------------------------------------------------------------
  The embedded terminal plugin was not included in gedit-plugins. The
  updated package was adjusted to include it.

http://www.linuxsecurity.com/content/view/149039 

* Mandriva: Subject: [Security Announce] [ MDVA-2009:090 ] mkinitrd (Jun 5)
  -------------------------------------------------------------------------
  This update fixes a minor issue with mkinitrd: - mount options for
  non-NFS mounts are ignored by the nash mount program

http://www.linuxsecurity.com/content/view/149038 

* Mandriva: Subject: [Security Announce] [ MDVSA-2009:129 ] file (Jun 5)
  ----------------------------------------------------------------------
  A security vulnerability has been identified and fixed in file:
  Heap-based buffer overflow in the cdf_read_sat function in src/cdf.c
  in Christos Zoulas file 5.00 allows user-assisted remote attackers to
  execute arbitrary code via a crafted compound document file, as
  demonstrated by a .msi, .doc, or .mpp file.  NOTE: some of these
  details are obtained from third party information (CVE-2009-1515).
  This update provides file-5.03, which is not vulnerable to this, and
  other unspecified issues.

http://www.linuxsecurity.com/content/view/149036 

* Mandriva: Subject: [Security Announce] [ MDVSA-2009:128 ] libmodplug (Jun 4)
  ----------------------------------------------------------------------------
  Multiple security vulnerabilities has been identified and fixed in
  libmodplug: Integer overflow in the CSoundFile::ReadMed function
  (src/load_med.cpp) in libmodplug before 0.8.6, as used in
  gstreamer-plugins and other products, allows context-dependent
  attackers to execute arbitrary code via a MED file with a crafted (1)
  song comment or (2) song name, which triggers a heap-based buffer
  overflow (CVE-2009-1438). Buffer overflow in the PATinst function in
  src/load_pat.cpp in libmodplug before 0.8.7 allows user-assisted
  remote attackers to cause a denial of service and possibly execute
  arbitrary code via a long instrument name (CVE-2009-1513). The
  updated packages have been patched to prevent this.

http://www.linuxsecurity.com/content/view/149032 

* Mandriva: Subject: [Security Announce] [ MDVA-2009:089 ] openssl (Jun 4)
  ------------------------------------------------------------------------
  This update fixes a build problem with openssl-0.9.7g-2.8.20060mlcs4
  on Corporate Server 4.

http://www.linuxsecurity.com/content/view/149031 

------------------------------------------------------------------------

* RedHat: Important: mod_jk security update (Jun 9)
  -------------------------------------------------
  Updated mod_jk packages that fix one security issue are now available
  for Red Hat Application Server v2. This update has been rated as
  having important security impact by the Red Hat Security Response
  Team.

http://www.linuxsecurity.com/content/view/149056 

------------------------------------------------------------------------

* Slackware:   ntp (Jun 4)
  ------------------------
  New ntp packages are available for Slackware 8.1, 9.0, 9.1, 10.0,
  10.1, 10.2, 11.0, 12.0, 12.1, 12.2, and -current to fix security
  issues. More details about this issue may be found in the Common
  Vulnerabilities and Exposures (CVE) database:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0159 
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1252 

http://www.linuxsecurity.com/content/view/149030 

------------------------------------------------------------------------

* SuSE: Linux kernel (SUSE-SA:2009:032) (Jun 9)
  ---------------------------------------------
http://www.linuxsecurity.com/content/view/149053 

* SuSE: Linux kernel (SUSE-SA:2009:031) (Jun 9)
  ---------------------------------------------
http://www.linuxsecurity.com/content/view/149050 

* SuSE: Linux kernel (SUSE-SA:2009:030) (Jun 8)
  ---------------------------------------------
http://www.linuxsecurity.com/content/view/149047 

------------------------------------------------------------------------

* Ubuntu:  ipsec-tools vulnerabilities (Jun 9)
  --------------------------------------------
  It was discovered that ipsec-tools did not properly handle certain
  fragmented packets. A remote attacker could send specially crafted
  packets to the server and cause a denial of service. (CVE-2009-1574)
  It was discovered that ipsec-tools did not properly handle memory
  usage when verifying certificate signatures or processing
  nat-traversal keep-alive messages. A remote attacker could send
  specially crafted packets to the server and exhaust available memory,
  leading to a denial of service. (CVE-2009-1632)

http://www.linuxsecurity.com/content/view/149057 

------------------------------------------------------------------------
Distributed by: Guardian Digital, Inc.                LinuxSecurity.com

To unsubscribe email vuln-newsletter-request@linuxsecurity.com 
         with "unsubscribe" in the subject of the message.
------------------------------------------------------------------------


_____________________________________________
Visit the InfoSec News security bookstore!
http://www.shopinfosecnews.org 

Site design & layout copyright © 1986-2014 CodeGods