Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Web :: CMS / Portals :: b1a-1282.htm

AneCMS SQL injection vulnerability



SQL injection vulnerability in AneCMS
SQL injection vulnerability in AneCMS



Vulnerability ID: HTB22408
Reference: http://www.htbridge.ch/advisory/sql_injection_vulnerability_in_anecms.html 
Product: AneCMS
Vendor: AneCMS Team
Vulnerable Version: 1.3 and Probably Prior Versions
Vendor Notification: 28 May 2010 
Vulnerability Type: SQL Injection
Status: Not Fixed, Vendor Alerted, Awaiting Vendor Response
Risk level: High 
Credit: High-Tech Bridge SA (http://www.htbridge.ch/) 

Vulnerability Details:
The vulnerability exists due to failure in the "/modules/blog/index.php" script. Attacker can alter queries to the application SQL database, execute arbitrary queries to the database, compromise the application, access or modify sensitive data, or exploit various vulnerabilities in the underlying SQL database.

Attacker can use browser to exploit this vulnerability. The following PoC is available:

http://host/blog/1+ANY_SQL_CODE_HERE/Demo_of_ANE_CMS#comment-63 





TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH