Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Linux :: Gentoo :: bx3062.htm

Horde Application Framework: Multiple vulnerabilities



Horde Application Framework: Multiple vulnerabilities
Horde Application Framework: Multiple vulnerabilities



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200805-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/ 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Horde Application Framework: Multiple vulnerabilities
      Date: May 05, 2008
      Bugs: #212635, #213493
        ID: 200805-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
Multiple vulnerabilities in the Horde Application Framework may lead to
the execution of arbitrary files, information disclosure, and allow a
remote attacker to bypass security restrictions.

Background
=========
The Horde Application Framework is a general-purpose web application
framework written in PHP, providing classes for handling preferences,
compression, browser detection, connection tracking, MIME and more.

Affected packages
================
    -------------------------------------------------------------------
     Package                   /  Vulnerable  /             Unaffected
    -------------------------------------------------------------------
  1  www-apps/horde                 < 3.1.7                   >= 3.1.7
  2  www-apps/horde-groupware       < 1.0.5                   >= 1.0.5
  3  www-apps/horde-kronolith       < 2.1.7                   >= 2.1.7
  4  www-apps/horde-mnemo           < 2.1.2                   >= 2.1.2
  5  www-apps/horde-nag             < 2.1.4                   >= 2.1.4
  6  www-apps/horde-webmail         < 1.0.6                   >= 1.0.6
    -------------------------------------------------------------------
     6 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
==========
Multiple vulnerabilities have been reported in the Horde Application
Framework:

* David Collins, Patrick Pelanne and the HostGator.com LLC support
  team discovered that the theme preference page does not sanitize POST
  variables for several options, allowing the insertion of NULL bytes
  and ".." sequences (CVE-2008-1284).

* An error exists in the Horde API allowing users to bypass security
  restrictions.

Impact
=====
The first vulnerability can be exploited by a remote attacker to read
arbitrary files and by remote authenticated attackers to execute
arbitrary files. The second vulnerability can be exploited by
authenticated remote attackers to perform restricted operations.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All Horde Application Framework users should upgrade to the latest
version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=www-apps/horde-3.1.7"

All horde-groupware users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=www-apps/horde-groupware-1.0.5"

All horde-kronolith users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=www-apps/horde-kronolith-2.1.7"

All horde-mnemo users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=www-apps/horde-mnemo-2.1.2"

All horde-nag users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=www-apps/horde-nag-2.1.4"

All horde-webmail users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=www-apps/horde-webmail-1.0.6"

References
=========
  [ 1 ] CVE-2008-1284
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1284 

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200805-01.xml 

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at 
http://bugs.gentoo.org. 

License
======
Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5 
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org 

iD8DBQFIH3dZuhJ+ozIKI5gRAh8VAJ4zaLHV1TKYxzVygklR+queUOB7BACgj9KU
HNgL2U4GaEj6VKejjpJltYo=6J+S
-----END PGP SIGNATURE-----


TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH