Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Linux :: Gentoo :: c07-2695.htm

PostgreSQL: Multiple vulnerabilities



PostgreSQL: Multiple vulnerabilities
PostgreSQL: Multiple vulnerabilities




--+SfteS7bOf3dGlBC
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200703-15
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/ 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: PostgreSQL: Multiple vulnerabilities
      Date: March 16, 2007
      Bugs: #165482
        ID: 200703-15

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
PostgreSQL contains two vulnerabilities that could result in a Denial
of Service or unauthorized access to certain information.

Background
=========
PostgreSQL is an open source object-relational database management
system.

Affected packages
================
    -------------------------------------------------------------------
     Package            /  Vulnerable  /                    Unaffected
    -------------------------------------------------------------------
  1  dev-db/postgresql      < 8.0.11                         >= 8.0.11
                                                            *>= 7.4.16
                                                            *>= 7.3.13

Description
==========
PostgreSQL does not correctly check the data types of the SQL function
arguments under unspecified circumstances nor the format of the
provided tables in the query planner.

Impact
=====
A remote authenticated attacker could send specially crafted queries to
the server that could result in a server crash and possibly the
unauthorized reading of some database content or arbitrary memory.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All PostgreSQL users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose "dev-db/postgresql"

References
=========
  [ 1 ] CVE-2007-0555
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0555 
  [ 2 ] CVE-2007-0556
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0556 

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200703-15.xml 

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at 
http://bugs.gentoo.org. 

License
======
Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5 

--+SfteS7bOf3dGlBC
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iQEVAwUBRfscnTvRww8BFPxFAQKUsgf9E1gGfSIt4fK4AoaaixN7a9l1c6zw8mpX
FwxDNDbuUJovLIBoypnvfQwvt7kTSAiUiY4mxC3TNVEEwGrfSx8rBlMPgSatsiIJ
0flG86ZEY7GWUb9pXQkG4KOIGkdkV4OpdqPxS1EEfbPkfIbvwQ1YFeVXAxqLNQvR
KYKNol1gTr8pBkXtkuQQ4FO3IIu/fyVX5AlVB4MCeDxtmCgSz9jcrCAC4Uvbi44V
R/3IZ1txeVu1ek7BKRIAOzx3m8OWRLqJlQzUSwUMv+8bKgo5j87PldYxsseL2bau
aTfacv8/gx3mni1QpjiOCOOqApu2cAStf1n7xmqNDU4ZXVINYTjMEw==mbSn
-----END PGP SIGNATURE-----

--+SfteS7bOf3dGlBC--


TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH