Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Linux :: Mandrake/Mandriva :: va1670.htm

emacs vulns



emacs
emacs




-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 _______________________________________________________________________

 Mandriva Linux Security Advisory                         MDVSA-2008:216
http://www.mandriva.com/security/ 
 _______________________________________________________________________

 Package : emacs
 Date    : October 27, 2008
 Affected: 2008.0, 2008.1
 _______________________________________________________________________

 Problem Description:

 A vulnerability was found in how Emacs would import python scripts from
 the current working directory during the editing of a python file.
 This could allow a local user to execute arbitrary code via a trojan
 python file (CVE-2008-3949).
 _______________________________________________________________________

 References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-3949 
 _______________________________________________________________________

 Updated Packages:

 Mandriva Linux 2008.0:
 0f3e9144bd142da817049a0136dfc817  2008.0/i586/emacs-22.1-5.4mdv2008.0.i586.rpm
 9c141a23c71252a0daf166a7d3128e4f  2008.0/i586/emacs-common-22.1-5.4mdv2008.0.i586.rpm
 906b37d0a5505f6c00e747af143719e4  2008.0/i586/emacs-doc-22.1-5.4mdv2008.0.i586.rpm
 75420dfc8e4f4509a28d211c4c760583  2008.0/i586/emacs-el-22.1-5.4mdv2008.0.i586.rpm
 d82ec0fa477c9d81d3099a6293cf0b4c  2008.0/i586/emacs-gtk-22.1-5.4mdv2008.0.i586.rpm
 1e76f2f7c7637bb2016ad8647897c782  2008.0/i586/emacs-leim-22.1-5.4mdv2008.0.i586.rpm
 19ef4e874af93f44526202947e8f8cd9  2008.0/i586/emacs-nox-22.1-5.4mdv2008.0.i586.rpm 
 f4bd28d40f9aa60b9b208435c2ca9b65  2008.0/SRPMS/emacs-22.1-5.4mdv2008.0.src.rpm

 Mandriva Linux 2008.0/X86_64:
 d45a236ecdbbd78e5edeb897773afd42  2008.0/x86_64/emacs-22.1-5.4mdv2008.0.x86_64.rpm
 c2433d5205782eb2f22948cf26129690  2008.0/x86_64/emacs-common-22.1-5.4mdv2008.0.x86_64.rpm
 a34710c80e1ef807adc76f6384d87ee5  2008.0/x86_64/emacs-doc-22.1-5.4mdv2008.0.x86_64.rpm
 34288614a1e7d5b36cfb0b7c5d4ad75d  2008.0/x86_64/emacs-el-22.1-5.4mdv2008.0.x86_64.rpm
 eef457c6672a91dd87a8976598d97bd4  2008.0/x86_64/emacs-gtk-22.1-5.4mdv2008.0.x86_64.rpm
 3388f5d1e4b746d3c8549daf3df41d3e  2008.0/x86_64/emacs-leim-22.1-5.4mdv2008.0.x86_64.rpm
 417347d28d5b82e7798f2434926c71e0  2008.0/x86_64/emacs-nox-22.1-5.4mdv2008.0.x86_64.rpm 
 f4bd28d40f9aa60b9b208435c2ca9b65  2008.0/SRPMS/emacs-22.1-5.4mdv2008.0.src.rpm

 Mandriva Linux 2008.1:
 d2b8c28e2a1b25f2ed07951b7a60ab71  2008.1/i586/emacs-22.1-7.3mdv2008.1.i586.rpm
 eb22bb15ab2a51683143d7e37bb0fff0  2008.1/i586/emacs-common-22.1-7.3mdv2008.1.i586.rpm
 e16ae2b47e560228b5e58bc2079fb3f9  2008.1/i586/emacs-doc-22.1-7.3mdv2008.1.i586.rpm
 c7052bec64abd1240f3678c284f91ded  2008.1/i586/emacs-el-22.1-7.3mdv2008.1.i586.rpm
 ade5f399427739ae753397a9daf529b2  2008.1/i586/emacs-gtk-22.1-7.3mdv2008.1.i586.rpm
 d40f79ac9da787464a0a1fc9e70d6718  2008.1/i586/emacs-leim-22.1-7.3mdv2008.1.i586.rpm
 743766677b25b5c451a3852c144d79d2  2008.1/i586/emacs-nox-22.1-7.3mdv2008.1.i586.rpm 
 2b1b580c675188c00331d75bf58588ef  2008.1/SRPMS/emacs-22.1-7.3mdv2008.1.src.rpm

 Mandriva Linux 2008.1/X86_64:
 d9ae92b3fa8040ff902d98efc546b7b4  2008.1/x86_64/emacs-22.1-7.3mdv2008.1.x86_64.rpm
 7bb684f012fc8fc36c9d2bc51444b3e9  2008.1/x86_64/emacs-common-22.1-7.3mdv2008.1.x86_64.rpm
 d79590801e9a4d1298ad73a055c44a89  2008.1/x86_64/emacs-doc-22.1-7.3mdv2008.1.x86_64.rpm
 33e94d0b48c8247ca554ba39d20c9263  2008.1/x86_64/emacs-el-22.1-7.3mdv2008.1.x86_64.rpm
 702f22945e72c54cab962d3a5ed97505  2008.1/x86_64/emacs-gtk-22.1-7.3mdv2008.1.x86_64.rpm
 153f652ed4cc446c5c6426cb0e9780cd  2008.1/x86_64/emacs-leim-22.1-7.3mdv2008.1.x86_64.rpm
 0a48de1c9f87fe81de158cf3af03d0dc  2008.1/x86_64/emacs-nox-22.1-7.3mdv2008.1.x86_64.rpm 
 2b1b580c675188c00331d75bf58588ef  2008.1/SRPMS/emacs-22.1-7.3mdv2008.1.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories 

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Mandriva Security Team
  
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFJBhDsmqjQ0CJFipgRAhwoAJ9kL+I2SJkvbW74Zj81rE+4YMfssACg8lZJ
mcTfuXGMAkBPkjy/XlMbMME=6Fc5
-----END PGP SIGNATURE-----



TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH