Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Web :: Wiki, Collaborationware :: b06-1395.htm

MediaWiki: Cross-site scripting vulnerability



MediaWiki: Cross-site scripting vulnerability
MediaWiki: Cross-site scripting vulnerability



--nextPart1482940.xrgLRp8xi6
Content-Type: text/plain;
  charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200604-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/ 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Low
     Title: MediaWiki: Cross-site scripting vulnerability
      Date: April 04, 2006
      Bugs: #127971
        ID: 200604-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
MediaWiki is vulnerable to a cross-site scripting attack that could
allow arbitrary JavaScript code execution.

Background
=========
MediaWiki is a collaborative editing software, used by big projects
like Wikipedia.

Affected packages
================
    -------------------------------------------------------------------
     Package             /  Vulnerable  /                   Unaffected
    -------------------------------------------------------------------
  1  www-apps/mediawiki      < 1.4.15                        >= 1.4.15

Description
==========
MediaWiki fails to decode certain encoded URLs correctly.

Impact
=====
By supplying specially crafted links, a remote attacker could exploit
this vulnerability to inject malicious HTML or JavaScript code that
will be executed in a user's browser session in the context of the
vulnerable site.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All MediaWiki users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/mediawiki-1.4.15"

References
=========
  [ 1 ] CVE-2006-1498
http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1498 
  [ 2 ] MediaWiki 1.4.15 Release Notes
http://sourceforge.net/project/shownotes.php?release_id=404869 

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200604-01.xml 

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at 
http://bugs.gentoo.org. 

License
======
Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0 

--nextPart1482940.xrgLRp8xi6
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

iD8DBQBEMmB6Epc7MgVybcQRArTuAJ4nMS5tevNWfWhZBmiU1GRQKf/93gCeJrOE
WGt4r3XXZgszJ4ZQOBovOsQ=AXhA
-----END PGP SIGNATURE-----

--nextPart1482940.xrgLRp8xi6--


TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH