Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Web :: Wiki, Collaborationware :: b06-2590.htm

WikiNi Persistent Cross Site Scripting Vulnerability



WikiNi Persistent Cross Site Scripting Vulnerability
WikiNi Persistent Cross Site Scripting Vulnerability



Hi,=0D
=0D
I've found a vulnerability more than 2 months ago, and notified the developers, but still no answer, so I'm posting here.=0D
=0D
http://zone14.free.fr/advisories/3/=0D 
=0D
Vendor: WikiNi=0D
Vulnerable: WikiNi 0.4.2 and below=0D
=0D
Persistent Cross Site Scripting=0D
=0D
A persistent XSS vulnerability is the most dangerous kind of XSS vulnerabilities, as the data submitted by the malicious user is stored permanently on the server. It could potentially hit a large number of other users with little need for social engineering.=0D
Just edit a page and insert: """"=0D
=0D
Restrictions=0D
The attacker needs to have the rights to edit at least one page of the wiki, but most of the time it is the case. Moreover, WikiNi 0.4.2 is used on more than 100,000 pages according to Google.=0D
=0D
--Rapha=EBl HUCK


TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH